Microsoft Word Document Compare

and

Side-by-Side Bill Comparison Procedures

Legislative Services Agency

Gigi Brickle, Director
1105 Pendleton Street
223 Blatt Building
Columbia, S.C. 29201
803-212-4420
Document Compare - Bill Side-by Side Comparison Procedures

Course Overview

Many times while working with bill text, Legislative Staff members need to compare two bills -- word by word -- to note the differences. The Microsoft Word Compare feature is a great tool for easily comparing two documents.

Network users who are unaware of the Compare feature would begin the grueling processing of reading the bills line-by-line in parallel. While this procedure is effective, it is too time consuming and unfeasible with today's technology so readily accessible.

In this course you will learn how to:

• Use the Microsoft Word Compare feature to compare two bills
  Especially helpful when comparing two versions of a bill.

• Use Microsoft Word Table feature to compare two or more bills
  Produces a great visible product for comparing bills

The accuracy and completeness of the information, illustrations, and opinions provided herein are suitable for the training of the staff and members of the South Carolina General Assembly only.

All brand names and product names in this book are trade names, service marks, trademarks, or registered trademarks of their respective owners.

© S.C. Legislative Services Agency

Gigi Brickle, Director
1105 Pendleton Street, 223 Blatt Building
Columbia, S.C. 29201
803-212-4420
Table of Contents

Comparing Two Bills ................................................................. 1
Comparison Results (Bills 3050 & 150) .................................... 4
Comparison Tips ......................................................................... 5
  Deleting the Top of a Bill (quick method) .................................. 6
Running the Bill Macro .............................................................. 10
Accessing a Previous Version of a Bill ........................................ 11
Bill Side-by-Side - Bill Comparison Procedures ......................... 15
Setting the Paper Orientation to Landscape ............................... 16
Setting Page Margins .................................................................. 16
Creating a Table ......................................................................... 17
Adding the Bills to the Table ...................................................... 18
Navigating a Word Table ............................................................ 20
Formatting a Table ..................................................................... 21
Running the Side-by-Side Template ............................................ 23
Listing of Network Macros ......................................................... 25
Microsoft Word
Document Compare
Comparing Two Bills

1. Open a new word document.
2. Open the first bill that you’d like to compare.
   a. Save the bill to an area on Network Drive L:\
   b. Delete
      • the Status Page and
      • the history information
      • the “VERSIONS OF THIS BILL” text
      • the Bill Title
      • “Be it enacted by the General Assembly of the State of South Carolina” text
      from the top of the bill.
   c. Resave the document - Giving it a meaningful name ie. Bill 250 April Version
   d. Close the document.

3. Open the 2nd bill that you’d like to compare.
4. Repeat steps 2a - 2d above

5. Click on the Review tab - located on the ribbon.

6. Click Compare
7. Select (Compare two versions of a document)
8. Click the 1st **drop down button** (on the left) and select the **first** Bill that you’d like to compare.

(This would be the document that you named in Step 2 above)

![Image 1](image1.png)

9. Click the 2nd **drop down button** (on the right) and select the **2nd** Bill that you’d like to compare.

(This would be the 2nd document that you named in Step 3 above)

![Image 2](image2.png)

10. Click the **button**
11. Verify that the following settings are **Unchecked**

![Compare Documents](image)

[Document Compare Figure 001]

Comments
Formatting
White Space
Tables
Headers and footers
Footnotes and endnotes
Text Boxes
Fields

12. Verify that the following settings are **selected**.
- Word Level
- New Document are selected.

13. Your settings should match those in Figure 001.
14. Click **OK**.
15. Comparison results will be displayed in a **new document** on your screen.
Comparison Results (Bills 3050 & 150)

1. SECTION 1. Section 24-13-100 of the 1976 Code is amended to read:

   "Section 24-13-100. (A) For purposes of definition under
   pursuant to South Carolina law, a 'no parole offense' means a class
   A, B, or C, D, E, or F felony, a class A, B, or C misdemeanor, or
   an offense exempt from classification as enumerated in Section
   16-1-10(d), which is punishable by a maximum term of
   imprisonment for twenty years, one year or more, or a class A or B
   misdemeanor."

2. (B) A person who is found guilty of, pleads guilty to, or pleads
   guilty or nolo contendere to a 'no parole offense' as defined in
   section subsection (A) is not eligible for early release from
   incarceration, except as provided in by Section 24-13-210(B).

3. Nothing in this section may be construed to amend, repeal, or
   affect the Youthful Offender Act contained in Chapter 19 of Title
   24."
Comparison Tips

1. The compare process uses the first bill (Bill 1) as the basis of the comparison.

**RED STRIKE THRU** is text in Bill 1 that is not in the Bill 2.

**BLUE UNDERLINE TEXT** is text that does not exist in Bill 1

2. **Printing the** comparison results document in color can be extremely helpful in the bill review process.

3. Files that you have *previously opened* are automatically listed (as a convenience) in the Compare drop-down list when the Compare feature is activated.

4. The listing of previously opened documents will be displayed in numeric/alpha order. Numeric files names will be listed 1st, followed by alphabetical file names.

5. Click the **Browse icon** to navigate to the location of files if desired files are not in the drop-down list.
Deleting the Top of a Bill (quick method)

1. Place your cursor at the end of the
   “Be it enacted by the General Assembly of the State of South Carolina” text

2. Press F8 (turns of selection mode)

3. Press Ctrl + (to delete text)

More Tips for Selecting Text

<table>
<thead>
<tr>
<th>Action</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Word</td>
<td>Double-Click</td>
</tr>
<tr>
<td>Sentence</td>
<td>Ctrl+Click</td>
</tr>
<tr>
<td>Paragraph</td>
<td>Triple + Click</td>
</tr>
<tr>
<td>Entire Document</td>
<td>Ctrl + a</td>
</tr>
</tbody>
</table>
EXERCISE 1 - Simple Document Comparison

1. Click on the **Review** tab - located on the ribbon.
2. Click **Compare**.
3. Select **(Compare two versions of a document)**
4. Click the 1<sup>st</sup> drop down button (on the left)
   - Navigate to the **Documents for Training** folder.
   - Select **Comparison Exercise Document 1.docx**
5. Click the 2<sup>nd</sup> drop down button (on the right)
   - Navigate to the **Documents for Training** folder.
   - Select **Comparison Exercise Document 2.docx**
6. Click the **More** button.
7. Uncheck the following settings:
   - Comments
   - Formatting
   - White Space
   - Tables
   - Headers and footers
   - Footnotes and endnotes
   - Text Boxes
   - Fields
8. Verify that the following settings **ARE selected**.
   - Word Level
   - New Document are selected
9. Click **OK**. Compare Results will display on your screen.

Comparison results should reveal the following differences.

**S.C. /South Carolina**
**neighborhood /area**
EXERCISE 2 - Simple Bills Comparison 425 & 3575

1. Click on the **Review** tab - located on the ribbon.
2. Click **Compare**.
3. Select **(Compare two versions of a document)**
4. Click the 1\(^{st}\) drop down button (on the left)
   - Navigate to the **Documents for Training** folder.
   - Select **425.docx**

5. Click the 2\(^{nd}\) drop down button (on the right)
   - Navigate to the **Documents for Training** folder.
   - Select **3575.docx**

6. Click the **More** button.

7. Uncheck the following settings:
   - Comments
   - Formatting
   - White Space
   - Tables
   - Headers and footers
   - Footnotes and endnotes
   - Text Boxes
   - Fields

8. Verify that the following settings **ARE selected**.
   - Word Level
   - New Document are selected

9. Click **OK**. Compare Results will display on your screen.

Comparison results should reveal the following results.
EXERCISE 3 - Complex Bill Comparison Bill 5 & Bill 3102

1. Click on the **Review** tab - located on the ribbon.
2. Click **Compare**.
3. Select *(**Compare two versions of a document**)*
4. Click the 1\(^{st}\) drop down button (on the left)
   - Navigate to the **Documents for Training** folder.
   - Select **5.docx**

5. Click the 2\(^{nd}\) drop down button (on the right)
   a. Navigate to the **Documents for Training** folder.
   b. Select **3102.docx**
6. Click the **More** button.
7. Uncheck the following settings:
   - Comments
   - Formatting
   - White Space
   - Tables
   - Headers and footers
   - Footnotes and endnotes
   - Text Boxes
   - Fields

8. Verify that the following settings **ARE selected**.
   - Word Level
   - New Document are selected.

9. Click **OK**. Compare Results will display on your screen.

**Comparison results should reveal several pages of results.**
Running the Bill Macro
(to open a Bill from the current session by bill number)

1. Press **Alt** + **F8**

2. Type **bill**

3. Press **Enter** or click **Run**

4. Type the bill number

5. Press **Enter**

*The full text version of the current bill will be displayed on your screen.*
Accessing a Previous Version of a Bill

Previous versions of bills are listed on the Status Page of each bill - just below the History of Legislative Actions section.

1. Point to the desired version date

2. Press \texttt{Ctrl} while clicking the modification date link to open the desired version of the Bill in Microsoft Word format.
Bill Side-by-Side
Bill Comparison Procedures
Bill Side-by-Side - Bill Comparison Procedures

First Things First

The best way to perform a side-by-side comparison of two or more bills is to use the Microsoft Word Table feature. The Table feature gives you the best control of text utilizing two more columns.

The best side-by-side bill comparisons have the following settings:
- 8.5 x 11 paper size
- Page Orientation - Landscape.
- Word table with two columns

The next few pages contain instructions on how to:
Set paper size, change page orientation and create a table for bill comparison.

It is best to use Paper Size 14 x 8.5 (Legal Size) for comparing 3 or more bills.
Setting the Paper Orientation to Landscape

The default setting for Paper Orientation is **Portrait**.

1. Select the **Page Layout** tab on the Ribbon.
2. Click the **Orientation** button.
3. Select **Landscape**.

Setting Page Margins

1. Select the **Page Layout** tab on the Ribbon.
2. Click the **Margins** button.
3. Choose **Custom Margins** (located at the bottom of the menu). The Page setup dialog box will appear.
   A. Set the **Top** Margin to .5
   B. Set the **Bottom** Margin to .5
   C. Set the **Left** Margin to .5
   D. Set the **Right** Margin to .5
4. Click **OK**.
Creating a Table

Table Basics

A table is made up of rows and columns. The intersection of a row and column is called a cell. An entire bill can be copied into 1 column (cell) of a table. You can then edit the bill text and align sections and paragraphs.

1. Create a new document.
2. Click the Insert tab on the Ribbon
3. Click the Table button.
4. Select Insert Table.
5. On the Insert Table dialogue box change the following fields:
   - Number of columns field: Type 2
   - Number of rows field: Type 1
6. Click OK.
Adding the Bills to the Table

1. Save your newly created Table document.
2. Open the modified version of the 1st bill that you have prepared for the compare process.
   A. **LSA recommends deleting**
      - the Status Page
      - the history information
      - the “VERSIONS OF THIS BILL” text
      - the Bill Title
      - “Be it enacted by the General Assembly of the State of South Carolina” paragraph

      from the top of the bill.

    B. **Resave** the document - Giving it a meaningful name i.e. Bill 250 April Version

3. Select the text that you’d like to compare
4. Click **Copy** on the Ribbon
5. Switch to the document that contains your table you just created.
6. Click once inside the first column of your table.
7. **Paste** the table text at your cursor position.

    *If your bill text has multiple pages, the pages will flow into multiple pages in the first column of your table.*

8. Open the modified version of the 2nd bill that you have prepared for the compare process.
9. Repeat steps 1A-1B (above) if necessary.
10. Select the text that you’d like to compare
11. Click **Copy** on the Ribbon
12. Switch to the document that contains your table you just created.
13. Click once inside the 2nd column of your table.
14. **Paste** the table text at your cursor position.
15. Modify text in each column by adding **RETURN’s** so that sections are aligned side-by-side in each column.
16. Resave your document frequently while editing and formatting.
**SAMPLE SIDE-BY-SIDE BILL COMPARISON**

<table>
<thead>
<tr>
<th>Bill Number: 8</th>
<th>Bill Number: 3570</th>
</tr>
</thead>
<tbody>
<tr>
<td>SECTION 1. Section 47-3-110 of the 1976 Code is amended to read:</td>
<td>SECTION 1. Section 47-3-110 of the 1976 Code is amended to read:</td>
</tr>
<tr>
<td>“Section 47-3-110. (A) If a person is bitten or otherwise attacked by a dog while the person is in a public place or is lawfully in a private place, including the property of the dog owner or person having the dog in the person’s care or keeping, the dog owner or person having the dog in the person’s care or keeping is liable for the damages suffered by the person bitten or otherwise attacked. For the purposes of this section, a person bitten or otherwise attacked is lawfully in a private place, including the property of the dog owner or person having the dog in the person’s care or keeping, when the person bitten or otherwise attacked is on the property in the performance of a duty imposed upon the person by the laws of this State, the laws of the United States of America including, but not limited to, postal regulations, or when the person bitten or otherwise attacked is on the property upon the invitation, express or implied, of the property owner or a lawful tenant or resident of the property.</td>
<td>“Section 47-3-110. (A) Whenever any dog if a person is bitten or otherwise attacked by a dog while the person is in a public place or is lawfully in a private place, including the property of the dog owner of the dog or other person having the dog in his care or keeping, the dog owner of the dog or other person having the dog in his care or keeping is liable for the damages suffered by the person bitten or otherwise attacked. For the purposes of this section, a person bitten or otherwise attacked is lawfully in a private place, including the property of the dog owner of the dog or other person having the dog in his care or keeping, when the person bitten or otherwise attacked is on the property in the performance of any a duty imposed upon him by the laws of this State, by the ordinances of any a political subdivision of this State, by the laws of the United States of America, including, but not limited to, postal regulations, or when the person bitten or otherwise attacked is on the property upon the invitation, express or implied, of the property owner of the property or of any a lawful tenant or resident of the property.</td>
</tr>
<tr>
<td>(B) This section does not apply if, at the time the person is bitten or otherwise attacked:</td>
<td>(B) The dog owner or other person having the dog in his care or keeping described in section (A) is not liable if:</td>
</tr>
<tr>
<td>(1) the person who was attacked provoked or harassed the dog and that provocation was the proximate cause of the attack; or</td>
<td>(1) the person that was attacked provoked or harassed the dog leading to the attack;</td>
</tr>
<tr>
<td>(2) the dog was working in a law enforcement capacity with a governmental agency and in the performance of the dog’s official duties provided that:</td>
<td>(2) the dog is working in a law enforcement capacity with a governmental agency and in the performance of its official duties provided that:</td>
</tr>
<tr>
<td>(a) the dog’s attack is in direct and complete compliance with the lawful command of a duly certified canine officer;</td>
<td>(a) the dog is trained and certified according to the standards adopted by the South Carolina Law Enforcement Training Council;</td>
</tr>
</tbody>
</table>
Navigating a Word Table

Next cell in a row

Previous cell in a row

Previous row

Next row

Pressing \texttt{Tab} in the last cell on a row will create a new blank row.
Formatting a Table

Deleting a row

1. Click and drag your mouse across the row
   OR
   Hold your mouse to the left of the row (in the left margin area) when an arrow appears, click to select the row.

2. Right-click.

3. Select Delete Rows from pop-up menu.

Deleting a Column

1. Click and drag your mouse down the column
   OR
   Hold your mouse at the top of the column; when a down arrow appears, click to select the column.

2. Right-click.

3. Select Delete Columns from pop-up menu.
Formatting a Table (continued)

To Insert a Row:
1) **Position the cursor in the table** where you would like to insert a row
2) Select the **Layout** tab on the Ribbon
3) Click either the **Insert Row Above** or the **Insert Row Below**

To Insert a Column
1) **Position the cursor in the table** where you would like to insert a column
2) Select the **Layout** tab on the Ribbon
3) Click either the **Insert Left** button or the **Insert Right** button

**Repeating the Header Row**

1. Hold your mouse to the left of the row that contains the table heading (in the left margin area).
2. When an arrow appears, click to select the row.
3. Click **Repeat Header Rows** button.
Running the Side-by-Side Template

1. Open Microsoft Word 2007

2. Click the Office button then New

3. Click My Templates.

4. Double-click the Side-by-Side template icon.
A new Side-by-Side Comparison table will be created on your screen.

<table>
<thead>
<tr>
<th>SIDE-BY-SIDE BILL COMPARISON</th>
</tr>
</thead>
<tbody>
<tr>
<td>Save this file with a meaningful file name.</td>
</tr>
<tr>
<td>Use the 'tab' key to move thru the table.</td>
</tr>
<tr>
<td>Pressing 'tab' on the last cell will add a new row.</td>
</tr>
<tr>
<td>Copy in 'SECTIONS' (or smaller subsections if needed) from each bill and position in cell. &quot;side by side&quot; if they are similar.</td>
</tr>
<tr>
<td>Delete this blue text when done.</td>
</tr>
<tr>
<td>Bill Number:</td>
</tr>
<tr>
<td>SECTION 1.</td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td></td>
</tr>
</tbody>
</table>

5. Save the document with a meaningful name
6. Refer to your instructions in this manual called:

"Adding the Bills to the Table"

to add bills to your Side-by-Side Comparison table
List of Network Macros

Running the Bill Macro
(to open a Bill from the current session by bill number)

1. Press \( + \)
2. Type \( \text{bill} \)
3. Press \( \text{Run} \) or click
4. Type the bill number
5. Press

The full text version of the current bill will be displayed on your screen.

<table>
<thead>
<tr>
<th>Macro Name</th>
<th>Function of Macro</th>
</tr>
</thead>
<tbody>
<tr>
<td>BILL</td>
<td>Retrieves a current bill with history and status page</td>
</tr>
<tr>
<td>B00</td>
<td>Retrieves a 1999-2000 session bill, with history &amp; status</td>
</tr>
<tr>
<td>B02</td>
<td>Retrieves a 2001-2002 session bill, with history &amp; status</td>
</tr>
<tr>
<td>B04</td>
<td>Retrieves a 2003-2004 session bill, with history &amp; status</td>
</tr>
<tr>
<td>B06</td>
<td>Retrieves a 2005-2006 session bill, with history &amp; status</td>
</tr>
<tr>
<td>B08</td>
<td>Retrieves a 2007-2008 session bill, with history &amp; status</td>
</tr>
<tr>
<td>B10</td>
<td>Retrieves a 2009-2010 session bill, with history &amp; status</td>
</tr>
<tr>
<td>B12</td>
<td>Retrieves a 2011-2012 session bill, with history &amp; status</td>
</tr>
<tr>
<td>B90</td>
<td>Retrieves a 1989-1990 session bill</td>
</tr>
<tr>
<td>B92</td>
<td>Retrieves a 1991-1992 session bill, with history &amp; status</td>
</tr>
<tr>
<td>B94</td>
<td>Retrieves a 1993-1994 session bill, with history &amp; status</td>
</tr>
<tr>
<td>B96</td>
<td>Retrieves a 1995-1996 session bill, with history &amp; status</td>
</tr>
<tr>
<td>B98</td>
<td>B06 a 1997-1998 session bill, with history &amp; status</td>
</tr>
</tbody>
</table>
BRAND ...................... BRANDS EACH PAGE OF DOCUMENT WITH FILENAME & PATH

CLIP ......................... RETRIEVES A BILL TITLE FROM THE CURRENT SESSION

CLIPS .......................... RETRIEVES MULTIPLE BILL TITLES FROM CURRENT SESSION

CODE .......................... RETRIEVES CODE OF LAWS -- USE TXXCXXX NAMING WHERE X IS A NUMBER (i.e. 2-12-36 is T02C012). Supplements are integrated.

COMPARE ...................... CONVERTS WORD’S COLOR DOCUMENT COMPARISON TO BLACK & WHITE

CONSTI .......................... RETRIEVES S.C. CONSTITUTION DOCUMENTS -- USE AXX NAMING WHERE X IS A NUMBER (i.e. Article 2 is A02. Amendments are Amend1, Amend2 and Amend3.)

DRAFTWATERMARK ....... INSERTS DRAFT AS A WATERMARK ACROSS PAGE

HC ............................... LISTS FILES IN THE HOUSE CALENDAR DIRECTORY, CALENDARS ARE LISTED BY DATE (YYYYMMDD)

HCAL ............................ RETRIEVES HOUSE INVITATIONS CALENDAR (select the month needed, click open)

HJ ............................... LISTS FILES IN THE HOUSE JOURNAL DIRECTORY, JOURNALS ARE LISTED BY DATE (YYYYMMDD)

HMEET ........................... RETRIEVES HOUSE MEETING SCHEDULE

PULLCLIP ........................ RETRIEVES CURRENT CLIP INTO DOCUMENT ON SCREEN
PULLCLIPS .................. RETRIEVES MULTIPLE CLIPS INTO DOCUMENT ON SCREEN

REG .......................... RETRIEVES A CURRENT REGULATION DOCUMENT

SC ............................ LISTS FILES IN THE SENATE CALENDAR DIRECTORY, CALENDARS ARE LISTED BY DATE (YYYYMMDD)

SCAL .......................... RETRIEVES SENATE INVITATIONS CALENDAR (macro prompts you type the month needed)

SJ .............................. LISTS FILES IN THE SENATE JOURNAL DIRECTORY, JOURNALS ARE LISTED BY DATE (YYYYMMDD)

SMEET .......................... RETRIEVES SENATE WEEKLY MEETING SCHEDULE